Merchant Portal Unavailable
Incident Report for TaxCloud
Resolved
This incident has been resolved.
Posted Dec 06, 2020 - 01:20 PST
Investigating
All API services are up and running. Merchant Portal is awaiting a separate database restore.
Posted Dec 05, 2020 - 23:06 PST
This incident affected: TaxCloud Merchant Interface (TaxCloud Reports, TaxCloud Merchant Account Services, TaxCloud Filings & Reports, TaxCloud Rate Finder).