Louisiana ransomware attack!
Incident Report for TaxCloud
Resolved
LA TAP is online and operational again. Filing deadlines further extended to November 27th.
http://revenue.louisiana.gov/LawsPolicies/RIB%2019-020.pdf
Posted Nov 25, 2019 - 21:52 PST
Monitoring
ALERT! State of Louisiana ransomware attack! Sales Tax Returns cannot be filed timely today. Extensions granted until 11/25/2019 via @larevenue #lagov #lalege #ecommerce #salestax #remoteseller #taxcloud - See Louisiana Department of Revenue Information Bulletin No. 19-017 https://go.taxcloud.com/lador-nov
Posted Nov 20, 2019 - 09:48 PST
This incident affected: TaxCloud Merchant Interface (TaxCloud Filings & Reports).