Network Access
Incident Report for TaxCloud
Resolved
Network access continues to be operating correctly. This incident has been resolved.
Posted Jun 30, 2020 - 23:30 PDT
Update
We are continuing to monitor for any further issues.
Posted Jun 30, 2020 - 21:28 PDT
Monitoring
Access to TaxCloud was restricted between 10:29:26 and 10:52:24 PM and may have affected some merchants. We have verified full network access has been restored and are monitoring for any changes.
Posted Jun 30, 2020 - 20:56 PDT