Serious Outage
Incident Report for TaxCloud
Resolved
Conclusion: As of June 1 at 5:18 pm EDT TaxCloud resumed normal operational status for all services.


Incident Summary: At 6:02 pm EDT on May 31, 2016 TaxCloud suffered a severe service outage caused by a calculated and malicious attack. The root source of the incident has been identified, vulnerabilities have been eliminated, and new protections are in place. TaxCloud has preserved important information and is assisting with forensic investigations now underway.


What We Know for Certain: No payment information or exemptions certificate information was compromised. Neither were any passwords compromised. All this data remained secure and protected.


Client Impact: Most merchant accounts have been recovered and are now fully accessible. However, some accounts created after February 14, 2016 may not yet be available. We are working to recover these accounts and will be reaching out directly to our customers who remain affected.


Recommended Actions:


  1. If you can access your account online, you are good to go for all future transactions, although we do suggest you change your password. See item 3 below.
  2. If your account was created after February 14, 2016 and you’ve been affected, you can quickly and easily reestablish your service by creating a new TaxCloud account using the same email address and other information previously registered with TaxCloud. We will ensure this new account information is properly reconciled with any account information subsequently recovered during our restoration efforts.
  3. While all passwords are encrypted in our systems and that data remained secure, we suggest you change your passwords as a standard advisable precaution for situations such as these. If you can access your account online, you can change your password by following this link. If you are recreating your account, you will be able to establish a new password during that process.


We’re Here to Help: If you’d like to call, we’re glad to talk. Feel free to phone us at 206-452-1686, but we kindly ask for your patience. Despite increasing our ability to handle higher call volumes, we believe in ensuring each customer receives all the attention they need and some callers require more assistance than others.


Key Message: We refuse to be intimidated by bad guys, nor will we be deterred from our mission to provide you and all retailers with free and easy-to-use sales tax processing. You deserve reliable, accurate, and headache-free service. We apologize for the inconvenience and we thank you for your understanding and support.

Posted over 2 years ago. Jun 02, 2016 - 09:40 PDT
Monitoring
TaxCloud has returned to normal operational status for all services.

Most merchant accounts have been recovered and are accessible. However, some accounts created after February 14, 2016, may not be available at present. We are working to recover those accounts affected, but in the meantime, you can create a new account (using the same email address as previously registered with TaxCloud).

Thank you for your understanding.
Posted over 2 years ago. Jun 01, 2016 - 14:45 PDT
Identified
19 Hours in.

We are diligently working to return to normal operations this afternoon.

We have identified the root cause of this incident and have taken steps preserve important information and data to assist the various investigations now underway.

Thank you for your generous outpouring of support while we are collectively enduring this unfortunate incident.
Posted over 2 years ago. Jun 01, 2016 - 10:11 PDT
Update
We are now 11 hours into this incident, and we still do not have an exact ETA on TaxCloud's return to normal operations. Thank you for your understanding while our investigation and remediation efforts continue.
Posted over 2 years ago. Jun 01, 2016 - 02:07 PDT
Update
No good news to report at this time. TaxCloud has suffered a calculated and catastrophic attack. The good news is no customer data has been compromised. The bad news is that it may take another 12 hours to return to normal operations. The moral of the story at this point: apparently offering free tax compliance services attracts enemies.
We will be back as soon as possible.
Thank you for your support and understanding.
Posted over 2 years ago. May 31, 2016 - 20:19 PDT
Investigating
This evening at about 6 PM EDT, TaxCloud began experiencing a severe network outage. We will update this as soon as we know the cause of the issue. Thank you for your patience.
Posted over 2 years ago. May 31, 2016 - 16:01 PDT