Replacement EV SSL Certificate
Incident Report for TaxCloud
Resolved
New EV SSL Certificate deployed @ 5:22 PM Eastern
Posted 4 days ago. Dec 05, 2018 - 14:22 PST
Identified
This afternoon we deployed an updated EV SSL Certificate which failed to include taxcloud.net (!). We have rolled back that new SSL certificate, awaiting a new replacement EV SSL Certificate.
Posted 4 days ago. Dec 05, 2018 - 14:04 PST