Merchant Login Issue with TaxCloud UI
Incident Report for TaxCloud
Resolved
Engineering has verified all API activity during the login issue was accepted normally. Issue fully resolved.
Posted 5 months ago. Apr 17, 2019 - 12:43 PDT
Investigating
TaxCloud merchants experienced an issue logging in to the TaxCloud UI between 14:30 - 15:00 Eastern US time. Engineering believes the issue has been resolved and the UI is operating normally once again. TaxCloud believes all transaction API activity was handled normally during this time and is verifying now. We will have confirmation in 30 minutes.
Posted 5 months ago. Apr 17, 2019 - 12:11 PDT
This incident affected: TaxCloud Merchant Interface (TaxCloud Merchant Account Services).