Happy Valentines Day - SSL/TLS Cipher Upgrades Complete
Incident Report for TaxCloud
Postmortem

This afternoon learned that related to this TLS Cipher Upgrade our namespace declaration was changed from http://taxcloud.net to https://api.taxcloud.net.

This namespace change was done with the best of intentions, but for implementations with cached WSDL data, this caused SOAP request errors. Our name space declaration has been reverted. Please reload our WSDL file (https://api.taxcloud.net/1.0/?wsdl) if you are experiencing any issues.

We will not change our namespace ever again (even though it references http rather than https).

Thank you.

Posted almost 3 years ago. Feb 14, 2016 - 14:58 PST

Resolved
Our Valentine's Day deployment went live at midnight, and with that our oldest server has resigned her post with TaxCloud to find greener (and less demanding) pastures.

She is an awesome server, and we are confident she will make her next business very happy - we will eagerly provide glowing references and even phone briefings as needed. She has been with us since the earliest days - and we are sad she is moving on, but we respect her dream of helping a simpler business in Bora Bora where the weather is beautiful, the bandwidth is very expensive (no major load requirements likely), and the sales tax rules are super easy (16% on everything, and at least 12% more on tourists).

We will always honor her memory for the house of TaxCloud she helped build - now one of the largest sales tax compliance services in the world!

Now that she has checked-in for her flight to Papeete, Tahiti (the International airport where she can transfer to a sailboat for the two day trip to Bora Bora), we are happy to report to all of our merchants and platform partners (in a whisper voice) - now that she has gone, our entire array of TaxCloud servers is now fully TLS 1.2 compliant.

Happy Valentines Day to all of our TaxCloud Merchants and Platform Partners.

We love you!
Posted almost 3 years ago. Feb 13, 2016 - 23:09 PST